Halp's performance is degraded

Incident Report for Halp

Resolved

The issue has been resolved
Posted Jun 15, 2021 - 15:53 UTC

Monitoring

We have identified the issue, and believe that the issue has been resolved. We will be continuing to monitor performance.
Posted Jun 15, 2021 - 15:30 UTC

Update

We are continuing to investigate this issue.
Posted Jun 15, 2021 - 15:21 UTC

Investigating

We are currently investigating this issue.
Posted Jun 15, 2021 - 15:21 UTC
This incident affected: Halp Web and Microsoft.