Halp Web is having an outage as a result of a Cloudflare outage
Incident Report for Halp
Resolved
This incident has been resolved.
Posted Jul 18, 2020 - 01:34 UTC
Update
Cloudflare has resolved their issues.
Posted Jul 18, 2020 - 01:34 UTC
Monitoring
Cloudflare seems to be stabilizing.
Posted Jul 17, 2020 - 21:37 UTC
Investigating
We are currently investigating this issue.
Posted Jul 17, 2020 - 21:31 UTC
This incident affected: Halp Web.