Halp Web degraded

Incident Report for Halp

Resolved

The issue has been resolved
Posted Oct 20, 2021 - 15:52 UTC

Investigating

We are seeing intermittent issues with accessing Halp Web
Posted Oct 20, 2021 - 15:49 UTC
This incident affected: Halp Web.